Android MaaS360 Browser Temporarily unavailable in Google Play : Feb 6, 2019
Incident Report for IBM MaaS360
Resolved
Issue is now resolved and the Android MaaS360 Browser is available in Google Play.
Posted 4 months ago. Feb 07, 2019 - 19:12 UTC
Monitoring
Android MaaS360 Browser Temporarily unavailable in Google Play - Feb 6, 2019

The MaaS360 team is currently working with Google to restore the ability to download the Android MaaS360 Browser from Google Play. For details on workarounds, please read details here: http://www.ibm.com/support/docview.wss?uid=ibm10870530
Posted 4 months ago. Feb 06, 2019 - 17:09 UTC